Support Hours

Conflict with Easy Front End SEO

More

Conflict with Easy Front End SEO

I had a problem with facebook Like buttons and Facebook share buttons since the beginning and could not find why. I endly finished understanding what is happening. Details in picture :

1) article published anything OK :



2) Then updating SEO datas (title and description fileds) with EFSEO extension :


3) After EFSEO data validation, page refresh and then :


no more facebook (neither like nor share buttons) everything's like if title or description was no more perceptible via facebook link


Expect you can do something
PS : the 3rd picture is the same as if I was connected with an another page than my main facebook account (did not know if it helps ?)

Attachments:

Last edit: 4 years 21 hours ago by PieceOfCake.

Please Log in or Create an account to join the conversation.

More

Conflict with Easy Front End SEO

Moderator

Hi,

I will have to test further but are you sure this isn't related to the page/site compression you are using? Social buttons being feed by JavaScript from their respective social networks such as countable vote buttons behave notoriously bad with page compression.

I will need to investigate further but an extension adding custom meta data to the page header would only be a problem if their is a JavaScript conflict. I will let you know what I find out.

Thanks,

Steve


Hi! I'm Steve the founder and head developer of CoalaWeb design studios. I'm an avid supporter of open source projects and the GPL license.

Please Log in or Create an account to join the conversation.

More

Conflict with Easy Front End SEO

Moderator

Hi,

I have run multiple tests with the Easy Front SEO extension updating Meta Data with the Panel displaying both before and after updates.



The most common reason for the Facebook button to stop displaying is website compression obstructing Facebooks ability to use the all.js JavaScript file. I think it appears to be a conflict because when the meta data is updated by EFE SEO it get re compressed which is causing the issue. You could try turning off your compression, clear your Joomla cache then update you meta data and see if on saving the panel disappears.

What type of compression are you using on your website?

Thanks,

Steve


Hi! I'm Steve the founder and head developer of CoalaWeb design studios. I'm an avid supporter of open source projects and the GPL license.

Attachments:

Last edit: 3 years 11 months ago by Steven Palmer.

Please Log in or Create an account to join the conversation.

More

Conflict with Easy Front End SEO

I think you're right after disabling JCH Optimize the problem disappears. will try to find the best way turning parameters on / off until it's work correctly.

Thanks for your answer. you can close this topic

Regards

Please Log in or Create an account to join the conversation.

More

Conflict with Easy Front End SEO

Moderator

I was working with a similar issue the other day with JCH Optimize and after running some test I found that I could exclude the Facebook Java Script file and leave the compression on.



In your case change the language code to French
//connect.facebook.net/fr_FR/all.js

Click add option paste it in and don't forget to select it afterwards so it look like the image above then save and clear your Joomla cache.

Thanks,

Steve


Hi! I'm Steve the founder and head developer of CoalaWeb design studios. I'm an avid supporter of open source projects and the GPL license.

Attachments:

Last edit: 3 years 11 months ago by Steven Palmer.

Please Log in or Create an account to join the conversation.

More

Conflict with Easy Front End SEO

seems you were right :) but I had to update my JCHOptimze version to 4.2.0 in order to get it (no regrets for my 10 bucks, work fine)

Thank for all and merry christmas to you


Best regards

Please Log in or Create an account to join the conversation.

Time to create page: 1.682 seconds

GET IN TOUCH

We will be glad to help you with any general or technical questions.