Support Hours

Monday - Friday
9am - 5pm
Saturday
10am - 4pm
Sunday
Closed
Our Current Time
11 August 2020
06:19
Your Current Time

CoalaWeb Social Links Module Icons not loading

More

CoalaWeb Social Links Module Icons not loading

Hi
The CoalaWeb Social Links Module is not loading the icons... I just have bullets instad of the icons... see attachement_1.
In the "Icons Styles" settings of the module I see the whole path of the theme folder... see attachement_2. Seems there is a bug which could have something to do with Joomla 3.6.2. The module worked with Joomla 3.6.

I had a similar issue with my T3-Framework-Plugin... see https://www.joomlart.com/forums/topic/theme-problems/ . In that case it was a folder listing problem.
Could it be that the CoalaWeb Social Links Module has the same problem?

Best regards
Oekkes

Attachments:

Please Log in or Create an account to join the conversation.

More

CoalaWeb Social Links Module Icons not loading

Moderator

Hi,

I'm currently using Joomla 3.6.2 on all my sites including the demo my development sites and I can't seem replicate this issue but it looks like it might be an issue specific to Xampp so lets try to work out what wrong.

I'll explain a bit, the Icon Styles form field seen in your image is using the form field type="folderlist" which lists all the folders in a specified directory in this case:

directory="media/coalawebsocial/components/sociallinks/themes-icon"

It appears that Joomla isn't able to understand the directory structure of you Xampp installation (which is weird considering you said it use to work) so something must have changed.

Let me do some research into the latest release to see what the Joomla developers have changed recently and the T3 link you provided.

Cheers,

Steve


Hi! I'm Steve the founder and head developer of CoalaWeb design studios. I'm an avid supporter of open source projects and the GPL license.

Last edit: 3 years 11 months ago by Steven Palmer.

Please Log in or Create an account to join the conversation.

More

CoalaWeb Social Links Module Icons not loading

Moderator

Hi again,

OK so this is a bug that is affecting Joomla and T3's own file list field

The proposed Joomla fix didn't make it into the latest Joomla release but give me a minute and I will give you some files that should fix the issue until the next update.

Cheers,

Steve


Hi! I'm Steve the founder and head developer of CoalaWeb design studios. I'm an avid supporter of open source projects and the GPL license.

Please Log in or Create an account to join the conversation.

More

CoalaWeb Social Links Module Icons not loading

Moderator

OK so I have made the proposed patch to the two Joomla library files and I have kept them in their same folder structure to make it easy to know where they go. Just download/extract/uploade these files , it might be worth renaming the current ones to something like -old just case you want to go back to them.

After clear you Joomla cache and see if the form fields work correctly.

Cheers,

Steve


Hi! I'm Steve the founder and head developer of CoalaWeb design studios. I'm an avid supporter of open source projects and the GPL license.

Please Log in or Create an account to join the conversation.

More

CoalaWeb Social Links Module Icons not loading

Hi Steve
Thanks for the explanation and fix. It's working now.
Best regards
Oekkes

Please Log in or Create an account to join the conversation.

More

CoalaWeb Social Links Module Icons not loading

Moderator

Great, I'm glad it's sorted.

Cheers,

Steve


Hi! I'm Steve the founder and head developer of CoalaWeb design studios. I'm an avid supporter of open source projects and the GPL license.

Please Log in or Create an account to join the conversation.

Time to create page: 0.104 seconds

GET IN TOUCH

We will be glad to help you with any general or technical questions.